Re: Most of the Permalink settings won’t work for me :(


Please try the following steps to resolve permalink issue,

1. Make sure that “mod_rewrite” rule is enabled for your hosting. It is normally enabled for most of the hosts.
2. Make sure that the root directory of your blog at your server is writable. This directly will be usually on most server is “htdocs” or “public_html”.
3. Make sure that .htaccess file is writable on your server. This file will be created by WordPress for rewrite rules which are required for SEO Permalinks.
4. After verifying the above steps, please choose your permalinks settings via Settings > Permalinks and save the changes.
5. After hitting the save changes button. You should give your attention that the Permalinks are successfully updated. Message will be like “Permalink structure updated.”

If you are unable to see this successful message. It means, you have to focus on first three steps.

Following article will also be helpful to you.