Re: how to remove comments option under images


– Go to `Media > Library`
– Click on any image, you wish to edit details
– Click on Edit more details
– Here you will find again, Screen Options and Comments control under the editor.

with regards to un-checking all the comments – EVERY option is already unchecked.
it still displays comments under each image! For example i have one image in a portfolio, I click on the portfolio on the home page, then click on the image when the portfolio opens and the option to leave comments is right underneath!